oj1025: To the Max(动态规划DP)

题目要求
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
Raw
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
Sample Output
Raw
15
Source
Greater New York 2001
这道题核心思想是将二维数组转化成一维数组,再利用一维数组的动态规划求连续最大数值,该方法与MAX SUM相似。
这里再附上大佬的讲解和思路
https://blog.csdn.net/qq_36336522/article/details/75733317
完整代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
using namespace std;
int main(void)
{
    int a[101][101], dp[101][101];
    int m;
    scanf("%d", &m);
    for (int i = 1; i <= m; i++)
    {
        for (int j = 1; j <= m; j++)
        {
            scanf("%d",&a[i][j]);
            dp[i][j] = dp[i][j - 1] + a[i][j];
        }
    }
    int sum, max = -128;
    for (int i = 1; i <= m; i++)
    {
        for (int j = i; j <= m; j++)
        {
            sum = 0;
            for (int k = 0; k <= m; k++)
            {
                sum += (dp[k][j]-dp[k][i-1]);
                if (sum > max)
                    {
                        max = sum;
                    }
                if (sum < 0)
                    {
                        sum = 0; 
                    }
            }   
        }
    }
    printf("%d\n", max);
    return 0;
}
发布了12 篇原创文章 · 获赞 2 · 访问量 181

猜你喜欢

转载自blog.csdn.net/qq_45891413/article/details/104686656