UVA#12096The SetStack Computer

• PUSH will push the empty set {} on the stack.
• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
• UNION will pop the stack twice and then push the union of the two sets on the stack.
• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set
on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}
and that the next one is
B = {{}, {{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.
Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each
test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of
the five commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with ‘***’ (three asterisks).
Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

#include<iostream>
#include<vector>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<algorithm>
#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
using namespace std;
typedef set<int> Set; 
map<Set,int> IDcache;
vector<Set> Setcache;//hashtable id -> set
int ID(Set x){//get ID for everyset
	if(IDcache.count(x))
		return IDcache[x];
	Setcache.push_back(x);
	return IDcache[x] = Setcache.size() - 1;
}
int main(){
	int p,T,n,i,j;
	string str;
	cin >> T;
	for(p = 0;p < T; ++p){
		cin >> n;
		stack<int> s;
		IDcache.clear();
		Setcache.clear();
		for(i = 0;i < n; ++i){
			cin >> str;
			if(str[0] == 'P')
				s.push(ID(Set ()));
			else if(str[0] == 'D'){
				s.push(s.top());
			}
			else{
				Set x1 = Setcache[s.top()];
				s.pop();
				Set x2 = Setcache[s.top()];
				s.pop();
				Set x;
				if(str[0] == 'U')
					set_union(ALL(x1),ALL(x2),INS(x));
				else if(str[0] == 'I')
					set_intersection(ALL(x1),ALL(x2),INS(x));
				else{
					x = x2;
					x.insert(ID(x1));
				}
				s.push(ID(x));
			}
			cout << Setcache[s.top()].size() << endl;
		}
		cout << "***" << endl;
	}
	return 0;
} 

——代码来自紫书。

发布了53 篇原创文章 · 获赞 0 · 访问量 724

猜你喜欢

转载自blog.csdn.net/weixin_38894974/article/details/104426906