O - Layout(差分约束 + spfa)

O - Layout(差分约束 + spfa)

Like everyone else, cows like to stand close to their friends when
queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1…N
standing along a straight line waiting for feed. The cows are standing
in the same order as they are numbered, and since they can be rather
pushy, it is possible that two or more cows can line up at exactly the
same location (that is, if we think of each cow as being located at
some coordinate on a number line, then it is possible for two or more
cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of
each other in line. Some really dislike each other and want to be
separated by at least a certain distance. A list of ML (1 <= ML <=
10,000) constraints describes which cows like each other and the
maximum distance by which they may be separated; a subsequent list of
MD constraints (1 <= MD <= 10,000) tells which cows dislike each other
and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance
between cow 1 and cow N that satisfies the distance constraints. Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2…ML+1: Each line contains three space-separated positive
integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at
most D (1 <= D <= 1,000,000) apart.

Lines ML+2…ML+MD+1: Each line contains three space-separated positive
integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at
least D (1 <= D <= 1,000,000) apart. Output Line 1: A single integer.
If no line-up is possible, output -1. If cows 1 and N can be
arbitrarily far apart, output -2. Otherwise output the greatest
possible distance between cows 1 and N.

Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27

Hint Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart,
cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3
dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put
cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

思路

  • 差分约束,让求最大答案,把所有给的不等式 转化为" <= " , 跑最短路径

题解(171ms)

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

#define INF 0x3f3f3f3f
const int maxn = 10005;
const int maxm = 200005;
int n,a,b;
struct Edge
{
    int v,w,next;
} edge[maxm];
int head[maxn], dis[maxn];
int use[maxn];
int k = 0;

void Add(int u,int v,int w)
{
    edge[++ k] = (Edge){ v, w, head[u]}; head[u] = k;
}

bool Spfa(int s, int e)
{
    int cnt[maxn] = {0};
    for(int i = 0; i <= n; i ++)
        dis[i] = INF;
    dis[s] = 0;
    queue<int> q;
    q.push(s);
    int u,v,w;
    while(! q.empty())
    {
        u = q.front(); q.pop();
        use[u] = 0;
        cnt[u] ++;
        if(cnt[u] > n + 1) return false;

        for(int i = head[u]; i; i = edge[i].next)
        {
            v = edge[i].v;
            w = edge[i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(! use[v])
                {
                    q.push(v);
                    use[v] = 1;
                }
            }
        }
    }
    return true;
}

int main()
{
    ios::sync_with_stdio(false); cin.tie(0);
    //freopen("T.txt","r",stdin);
    cin >> n >> a >> b;
    int u,v,w;
    for(int i = 1; i <= a; i ++)
    {
        cin >> u >> v >> w;
        Add(u, v, w);
    }
    for(int i = 1; i <= b; i ++)
    {
        cin >> u >> v >> w;
        Add(v, u,-w);
    }
    if(Spfa(1, n))
    {
        if(dis[n] == INF) cout << -2 << endl;
        else              cout << dis[n] << endl;
    }
    else
        cout << -1 << endl;

    return 0;
}
//分析:让求的事最大距离 -> 跑最短路

kuangbin的题解(47ms)

/*
POJ 3169 Layout

差分约束+SPFA
*/
//队列实现SPFA,需要有负环回路判断
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

const int MAXN=1010;
const int MAXE=20020;
const int INF=0x3f3f3f3f;
int head[MAXN];//每个结点的头指针
int vis[MAXN];//在队列标志
int cnt[MAXN];//每个点的入队列次数
int que[MAXN];//SPFA循环指针
int dist[MAXN];

struct Edge
{
    int to;
    int v;
    int next;
}edge[MAXE];
int tol;
void add(int a,int b,int v)//加边
{
    edge[tol].to=b;
    edge[tol].v=v;
    edge[tol].next=head[a];
    head[a]=tol++;
}
bool SPFA(int start,int n)
{
    int front=0,rear=0;
    for(int v=1;v<=n;v++)//初始化
    {
        if(v==start)
        {
            que[rear++]=v;
            vis[v]=true;
            cnt[v]=1;
            dist[v]=0;
        }
        else
        {
            vis[v]=false;
            cnt[v]=0;
            dist[v]=INF;
        }
    }
    while(front!=rear)
    {
        int u=que[front++];
        vis[u]=false;
        if(front>=MAXN)front=0;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dist[v]>dist[u]+edge[i].v)
            {
                dist[v]=dist[u]+edge[i].v;
                if(!vis[v])
                {
                    vis[v]=true;
                    que[rear++]=v;
                    if(rear>=MAXN)rear=0;
                    if(++cnt[v]>n) return false;
                    //cnt[i]为入队列次数,用来判断是否存在负环回来
                    //这条好像放在这个if外面也可以??
                }
            }
        }
    }
    return true;
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    int ML,MD;
    int a,b,c;
    while(scanf("%d%d%d",&n,&ML,&MD)!=EOF)
    {
        tol=0;//加边计数,这个不要忘
        memset(head,-1,sizeof(head));
        while(ML--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a>b)swap(a,b);//注意加边顺序
            add(a,b,c);
            //大-小<=c ,有向边(小,大):c
        }
        while(MD--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a<b)swap(a,b);
            add(a,b,-c);
            //大-小>=c,小-大<=-c,有向边(大,小):-c
        }
        if(!SPFA(1,n)) printf("-1\n");//无解
        else if(dist[n]==INF) printf("-2\n");
        else printf("%d\n",dist[n]);
    }
    return 0;
}
发布了136 篇原创文章 · 获赞 218 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_34261446/article/details/104642578