PAT A1033 To Fill or Not to Fill (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805458722734080

题目描述
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入
Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg
​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​ , the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

输出
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

样例输出
749.17

代码

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 510;
const int INF = 100000000;

struct station{
	double price, dis;
}st[maxn];

bool cmp(station a, station b) {
	return a.dis < b.dis;
}

int main() {
	int n;
	double Cmax, D, Davg;
	scanf("%lf%lf%lf%d", &Cmax, &D, &Davg, &n);
	for(int i = 0; i < n; i++)
		scanf("%lf%lf", &st[i].price, &st[i].dis);
	st[n].price = 0;
	st[n].dis = D;
	sort(st, st + n, cmp);
	if(st[0].dis != 0)
		printf("The maximum travel distance = 0.00\n");
	else {
		int now = 0;
		double ans = 0, nowtank = 0, max = Cmax * Davg;
		while(now < n) {
			int k = -1;			//标记下一个加油站的位置
			double pricemin = INF;
			for(int i = now  + 1; i <= n && st[i].dis - st[now].dis <= max; i++) {
				if(st[i].price < pricemin) {
					pricemin = st[i].price;
					k = i;
					if(pricemin < st[now].price)
						break;
				}
			}
			if(k == -1)			//未找到
				break;
			double need = (st[k].dis - st[now].dis) / Davg;
			if(pricemin < st[now].price) {
				if(nowtank < need) {
					ans += (need - nowtank) * st[now].price;
					nowtank = 0;
				}
				else
					nowtank -= need;
			}
			else {
				ans += (Cmax - nowtank) * st[now].price;
				nowtank = Cmax - need;
			}
			now = k;
		}
		if(now == n)
			printf("%.2f\n", ans);
		else
			printf("The maximum travel distance = %.2f\n", st[now].dis + max);
	}
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104736035