PAT (Advanced Level) 1033 To Fill or Not to Fill (25 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/88581531

1033 To Fill or Not to Fill (25 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
double Cmax, Dis, gas2dis;
int staNum;
struct Sta
{
	double p, d;
	Sta(double p_, double d_) :p(p_), d(d_) {}
	Sta() {  };
};
int main()
{
	scanf("%lf%lf%lf%d", &Cmax, &Dis, &gas2dis, &staNum);
	vector<Sta> sta(staNum);
	for (int i = 0; i < staNum; i++)
		scanf("%lf%lf", &sta[i].p, &sta[i].d);
	sta.push_back(Sta(0.0, Dis));
	sort(sta.begin(), sta.end(), [](const Sta& s1, const Sta& s2) {
		return s1.d < s2.d;
	});
	double curr_c = 0.0, totalPrice = 0.0, curr_dis = 0.0;
	int last_sta = 0;
	if (sta[0].d > 0.0) {
		printf("The maximum travel distance = 0.00\n");
		return 0;
	}
	while (curr_dis < Dis)
	{
		int index = last_sta;
		double price = 30.0;
		bool flag = false;
		for (int i = last_sta + 1; i < sta.size() && sta[i].d <= curr_dis + Cmax * gas2dis; i++)
			if (sta[i].p < sta[last_sta].p) {
				totalPrice += sta[last_sta].p * ((sta[i].d - sta[last_sta].d) / gas2dis - curr_c);
				curr_c = 0.0;
				curr_dis = sta[i].d;
				last_sta = i;
				flag = true;
				break;
			}
			else if(sta[i].p < price){
				index = i;
				price = sta[i].p;
			}
		if (index == last_sta) {
			printf("The maximum travel distance = %.2f\n", curr_dis + Cmax * gas2dis);
			return 0;
		}
		else if (!flag){
			totalPrice += sta[last_sta].p * (Cmax - curr_c);
			curr_c = Cmax - ((sta[index].d - sta[last_sta].d) / gas2dis);
			curr_dis = sta[index].d;
			last_sta = index;
		}
	}
	printf("%.2f\n", totalPrice);
	return 0;
}

思路:

https://www.liuchuo.net/archives/2461

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/88581531