PAT A1083 List Grades (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805383929905152

题目描述
Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

输入
Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

输出
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

样例输入
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

样例输出
Mike CS991301
Mary EE990830
Joe Math990112

代码

#include <cstdio>
#include <algorithm>

using namespace std;

struct student {
	char name[20];
	char id[20];
	int grade;
}stu[110];

bool cmp(student a, student b) {
	return a.grade > b.grade;
}

int main(){
	int n, flag = 1;
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
		scanf("%s %s %d", stu[i].name, stu[i].id, &stu[i].grade);
	sort(stu, stu + n, cmp);
	int min, max;
	scanf("%d%d", &min, &max);
	for(int i = 0; i < n; i++) {
		if(stu[i].grade >= min && stu[i].grade <= max) {
			printf("%s %s\n", stu[i].name, stu[i].id);
			flag = 0;
		}
	}
	if(flag)
		printf("NONE\n");
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104712588