PAT-A 1083 List Grades (25 分)

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

分析:超低配版A1055,就简单排序然后遍历输出,题目还保证所有分数不同。25分的题和25分的题差距真的大,同分不同命。这也说明了考PAT还是要看一点脸的。

#include <cstdio>
#include <algorithm>

using namespace std;
typedef struct stu
{
    char name[11];
    char id[11];
    int grade;
}stu;

bool cmp(stu a, stu b)
{
    return a.grade > b.grade;
}
int main()
{
    int n;
    scanf("%d", &n);



    stu all[n];
    for(int i = 0; i < n; i++)
    {
        scanf("%s %s %d", all[i].name, all[i].id, &all[i].grade);
    }

    sort(all, all + n, cmp);

    int low, high;
    scanf("%d %d", &low, &high);
    int num = 0;
    for(int i = 0; i < n; i++)
    {
        if(all[i].grade >= low && all[i].grade <= high)
        {
            printf("%s %s\n", all[i].name, all[i].id);
            num++;
        }
    }
    if(num == 0)
        printf("NONE\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38127801/article/details/86490980