POJ-2386___水洼——解题报告 DFS

原题链接:http://poj.org/problem?id=2386

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 40211   Accepted: 19937

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.


题目大意:

给出一张图,‘w’为水,以w为中心的九宫格内的w相连形成水洼,水洼与水洼之间被‘.’相隔。

扫描二维码关注公众号,回复: 1022135 查看本文章

问一共有几个水洼。


解题思路:

DFS即可


代码思路:

1、用二维数组存储地图

2、每次访问到的‘w’点都更改为‘.’

3、访问到的‘w’以九宫格范围dfs

4、dfs次数即为水洼个数


核心:本题关键在于访问到的点用取消标记!

代码:

#include <iostream>  
#include<cstdio>  
using namespace std;  
#define maxn 105  
char field[maxn][maxn];  
int n,m;  
void dfs(int x,int y)  
{  
     field[x][y]='.';
     for(int dx=-1;dx<=1;dx++)  
        for(int dy=-1;dy<=1;dy++) 
     	{
     		int xx=x+dx,yy=y+dy;
     		if(xx>=0&&xx<n&&yy<m&&yy>=0&&field[xx][yy]=='W') dfs(xx,yy);
		 }
}  
void solve()  
{  
     int ans=0;
     for(int i=0;i<n;i++)
	 	for(int j=0;j<m;j++)
	 		if(field[i][j]=='W') 
	 		{
	 			dfs(i,j);
	 			ans++;
			 }
     
     cout<<ans;
}  
int main()  
{  
    std::ios::sync_with_stdio(false);
    cin>>n>>m;
	for(int i=0;i<n;i++)
	 	for(int j=0;j<m;j++)
		 	cin>>field[i][j];
	solve();
    return 0; 
}  

猜你喜欢

转载自blog.csdn.net/scar_halo/article/details/79378323