POJ 3254 Corn Fields


Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18759   Accepted: 9868

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
#include<cstdio>
#include<string.h>
using namespace std;
const int mod=100000000;
#define ll long long
ll dp[1<<13][2];
ll f[13];
int a[13][13];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
    	memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                scanf("%d",&a[i][j]);
        ll sum=0;
        for(int i=0; i<n; i++)
        {
            ll t=0;int k=i%2;
            for(int S=(1<<m)-1; S>0; S--)//枚举每行状态
            {
                bool bb=1;
                for(int j=0; j<m; j++)
                {
                    if(S>>j&1)
                    {
                        if(j==0||!(S>>(j-1)&1))
                        {
                            if(!a[i][j])
                            {
                                bb=0;
                                break;
                            }
                        }
                        else
                        {
                            bb=0;
                            break;
                        }
                    }
                }
                if(!bb)continue;//此行不合法,这个剪枝很重要,大部分状态都不合法
                dp[S][k]=(sum+1)%mod;
                for(int S1=0;S1<1<<m;S1++)
				{
					if(S&S1)
						dp[S][k]=(dp[S][k]-dp[S1][k^1]+mod)%mod;//减掉与上一行冲突的状态
					//printf("%lld\n",dp[S][k]);

				}
				t=(t+dp[S][k])%mod;
            }
            for(int S=0;S<1<<m;S++)
				dp[S][k^1]=0;//清零
            sum=(sum+t)%mod;
            //printf("%lld\n",t);
        }
        printf("%lld\n",(sum+1)%mod);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/albertluf/article/details/80336534