1035 Password (20分)【字符串处理】

1035 Password (20分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

 题目大意:

给定N个用户姓名和密码,现在需要把密码中的‘1’改为‘@’、‘0’改为‘%’、‘l'改为’L'、‘O'改为’o'。

其中尤其注意输出格式!

#include<iostream>
#include<string>
#include<vector>
using namespace std;

string str[1010][2];
vector<int>modified;

int replace(int pos)
{
	int len = str[pos][1].length();
	int flag = 0;
	for (int i = 0; i < len; i++)
	{
		if (str[pos][1][i] == '1')
		{
			flag = 1;
			str[pos][1][i] = '@';
		}
		else if (str[pos][1][i] == '0')
		{
			flag = 1;
			str[pos][1][i] = '%';
		}
		else if (str[pos][1][i] == 'O')
		{
			flag = 1;
			str[pos][1][i] = 'o';
		}
		else if (str[pos][1][i] == 'l')
		{
			flag = 1;
			str[pos][1][i] = 'L';
		}
	}
	if (flag)
	{
		modified.push_back(pos);
		return 1;
	}
	return 0;

}

int main()
{
	int n;
	cin >> n;
	int cnt = 0;
	for (int i = 0; i < n; i++)
	{
		cin >> str[i][0]>>str[i][1];
		if (replace(i))
			cnt++;
	}
	if (cnt == 0)
	{
		if (n == 1)
			cout << "There is 1 account and no account is modified" << endl;
		else
			cout << "There are " << n << " accounts and no account is modified" << endl;
	}
	else
	{
		cout << cnt << endl;
		for (int i = 0; i < modified.size(); i++)
		{
			cout << str[modified[i]][0] << " " << str[modified[i]][1] << endl;
		}
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104644191