杭电 oj 1097 A hard puzzle C++

Problem Description lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output For each test case, you should output the a^b’s last digit number.

Sample Input
7 66
8 800
Sample Output
9
6

#include"iostream"
using namespace std;
int main()
{
 int a,b,c[4],t,n;
 while(cin>>a>>b)
 {
  t=a%10;
  c[1]=t;
  c[2]=t*c[1]%10;
  c[3]=t*c[2]%10;
  c[0]=t*c[3]%10;//尾数一共四种情况 
  n=c[b%4];
  cout<<n<<endl; 
 }
return 0;
}
发布了23 篇原创文章 · 获赞 8 · 访问量 435

猜你喜欢

转载自blog.csdn.net/qq_45697900/article/details/105106177