HDU1097-A hard puzzle(快速幂运算模板)

题目链接:https://vjudge.net/problem/10781/origin

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.

Sample Input
7 66
8 800
Sample Output
9
6

快速幂运算模板

//pow(x,n)%mod
typedef long long ll;
ll mod_pow(ll x,ll n,ll mod){//时间复杂度O(logn) 
	ll ans=1;
	while(n>0){
		if(n&1)
			ans=ans*x%mod;
			x=x*x%mod;
			n>>=1;
	}
	return ans;
} 

求pow(a,b)%10;

#include<iostream>
using namespace std;
//pow(x,n)%mod
typedef long long ll;
ll mod_pow(ll x,ll n,ll mod){//时间复杂度O(logn) 
	ll ans=1;
	while(n>0){
		if(n&1)
			ans=ans*x%mod;
			x=x*x%mod;
			n>>=1;
	}
	return ans;
} 
int main(){
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
		cout<<mod_pow(a,b,10)<<endl;
}
/*Sample Input
7 66
8 800
Sample Output
9
6*/
发布了73 篇原创文章 · 获赞 27 · 访问量 1265

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103635704