Simpsons’ Hidden Talents (kmp--next[])

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21712 Accepted Submission(s): 7397

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input
clinton
homer
riemann
marjorie

Sample Output
0
rie 3

Source
HDU 2010-05 Programming Contest

Recommend
lcy

//#include"string" 比 cstring 好用

#pragma warning(disable:4996)
#include"iostream"
#include"functional"
#include"algorithm"
//#include"cstring"
#include"string"
#include"stack"
#include"cmath"
#include"queue"
#include"vector"
#include"map"
typedef long long int ll;
using namespace std;
ll nex[1000009];
string h;
void get_next(){
	ll k=-1;
	nex[0]=-1;
	ll i=0;
	while(i<h.size()){
		if(k==-1||h[i]==h[k]) nex[++i]=++k;
		else{
			k=nex[k];
		}
	}
}
int main(){
	string s,s1;
	while(cin>>s>>s1){
		h=s+s1;
		get_next();
		ll cnt;
		cnt=nex[h.size()];
		while(cnt>s1.size()||cnt>s.size()) cnt=nex[cnt];
		for(int i=0;i<cnt;i++){
			cout<<s[i];
			if(i==cnt-1) cout<<" "; 
		}
		cout<<cnt<<endl;
	}
} 
发布了49 篇原创文章 · 获赞 0 · 访问量 660

猜你喜欢

转载自blog.csdn.net/qq_14989799/article/details/105406869