Simpsons’ Hidden Talents (KMP)

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意:给出两个字符串,让你判断第一个字符串的前缀和第二个字符串的后缀最大匹配度,如果有匹配的,输出那些字符,并输出有几个;如果没有匹配的,则输出0。

分析:(1)、可以让输入的两个穿的顺序调整一下,把问题变成寻找a串的后缀与b串的前缀的最大匹配度。就相当于a串是子串,b串是主串了。

(2)、也可以利用next数组的含义,将b串放在a串的后面,这样,问题就变成寻找字符串的前缀与后缀最大匹配度的问题了。

#include<stdio.h>
#include<string.h>
char a[50010],b[50010];
int lena,lenb,next[50010];
void get_next()
{
	int i = 1, j = 0;
	while(i < lenb)
	{
		if(j == 0 && b[i] != b[j])
		{
			next[i] = 0;
			i ++;
		}
		else if(j > 0 && b[i] != b[j])
			j = next[j-1];
		else
		{
			next[i] = j+1;
			i ++; j ++;
		}
	}
}
int kmp()
{
	int i = 0, j = 0;
	while(i < lena)
	{
		if(j == 0 && a[i] != b[j])
			i ++;
		else if(j > 0 && a[i] != b[j])
			j = next[j-1];
		else
		{
			i ++; j ++;
		}
	}
	return j;
}
int main()
{
	int i,k;
	while(scanf("%s%s",b,a) != EOF)
	{
		lena = strlen(a);
		lenb = strlen(b);
		get_next();
		k = kmp();
		if(k == 0)
			printf("0\n");
		else
		{
			for(i = 0; i < k; i++)
				printf("%c",b[i]);
			printf(" %d\n",k);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81167976