动态规划21 fast food

Fast Food

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 69   Accepted Submission(s) : 26

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots. 

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built. 

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized. 

Input

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed. 

Output

For each chain, first output the number of the chain. Then output a line containing the total distance sum. 

Output a blank line after each test case.

Sample Input

6 3
5
6
12
19
20
27
0 0

Sample Output

Chain 1
Total distance sum = 8


#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

int dp[203][33];//dp[i][j]代表从头放到i放
int val[203];
int S[203][203];//任意n个餐厅之间放一个仓库的最小值,不管奇数偶数,仓库放中间

int main()
{
	int n, k;
	int time = 1;
	while (cin >> n >> k,n+k)
	{
		for (int i = 1; i <= n; ++i)
			cin >> val[i];
		for (int i = 1; i <= n; ++i)
		{
			for (int j = i; j <= n; ++j)
			{
				int temp = (i + j) / 2;
				int sum = 0;
				for (int p = i; p <= j; ++p)
				{
					sum += abs(val[p] - val[temp]);
				}
				S[i][j] = sum;
				if (i == 1)
				{
					dp[j][1] = S[i][j];
				}
			}
		}

		//状态转移:dp[i][j]=dp[k][j-1]+S[k+1][i]
		//意思就是指在第k个餐厅放第j-1个仓库,然后再在剩余的从k+1到i的餐厅中放一个仓库,的最小值
		for (int j = 2; j <= k; ++j)
		{
			for (int i = j; i <= n; ++i)
			{
				int minb = INT_MAX;
				for (int p = j - 1; p <= i - 1; ++p)
				{
					int temp = dp[p][j - 1] + S[p + 1][i];
					if (temp < minb)
						minb = temp;
				}
				dp[i][j] = minb;
			}
		}
		printf("Chain %d\n", time);
		time++;
		printf("Total distance sum = %d\n\n", dp[n][k]);
	}
	system("pause");
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_36921652/article/details/79204496