PAT1080 Graduate Admission 《论正确理解题意的重要性--续》

1080. Graduate Admission (30)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​ , and the interview grade G​I​​ . The final grade of an applicant is (G​E​​ +G​I​​ )/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I , respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output

0 10
3
5 6 7
2 8

1 4

  题目大意就是要你写个程序把莘莘学子们安排进高校里头,这些人每个人都有若干个志愿,每所高校也有一定名额限制,录取过程按照排名来,排名按照给定的规则来。同排名的学生应当能够进入同一所学校,即使录取之后人数超过额定的上限。

  第一次提交的时候就只有测试点4不能通过,改来改去还是不能通过,看了别人的代码发现唯一的区别在于:我的代码先遍历学生填的所有的高校,看是否有名额,然后再遍历一次判断是否能超额录取,一共遍历两趟志愿。正确的做法应该是:遍历学生志愿所填的高校,如果学生有超额录取的资格就无脑录取,不行再看有没有名额。 不瞒大家说,AC的时候我人有点傻,我不断的质问自己:你的阅读能力到底是有多差啊!?于是我仔仔细细的又读了几遍题目,发现我出错的地方,就是原题干中加粗的部分

even if its quota will be exceeded.

  重点就在这个 “even if” 的理解上面。Event happens when A, even if B. 这就是说判断事件Event发生与否时,条件A凌驾于B之上。在这题里面就是“学校应当接收学生”(事件)在“学校已经接收了相同排名的学生”(A)这个条件达成时,无论“学校有名额”(B)这个条件是否成立,都应当发生。简而言之此时无视学校的剩余名额。

   我感觉这种低级的理解错误(甚至都不能称为错误)需要我的经验或者细心程度有一个质的变化才能规避啊(╯﹏╰)

代码如下:

#include <bits/stdc++.h>
using namespace std;
struct node{
    int ge,gi,avg,rank;
    int id,res;
    vector<int> choice;
};
vector<int> quota,lastrank;//lastrank是每所学校上一个录取学生的排名
vector<node> stu;
vector<vector<int> > ans;
int n,m,k;
bool cmp(const node &a,const node &b){
    if(a.avg!=b.avg) return a.avg>b.avg;
    else return a.ge>b.ge;
}
int main(){
    //freopen("input.md","r",stdin);
    scanf("%d%d%d",&n,&m,&k);
    quota.resize(m);
    stu.resize(n);
    ans.resize(m);
    lastrank.resize(m);
    for(int i=0;i<m;i++){
        scanf("%d",&quota[i]);
    }
    for(int i=0;i<n;i++){
        scanf("%d%d",&stu[i].ge,&stu[i].gi);
        stu[i].choice.resize(k);
        for(int j=0;j<k;j++){
            scanf("%d",&stu[i].choice[j]);
        }
        stu[i].avg=stu[i].ge+stu[i].gi;
        stu[i].id=i;
    }
    sort(stu.begin(),stu.end(),cmp);
    stu[0].rank=1;
    for(int i=1;i<n;i++){//根据排序结果对学生赋予排名
        if(stu[i].avg!=stu[i-1].avg)
            stu[i].rank=i+1;
        else if(stu[i].ge!=stu[i-1].ge)
            stu[i].rank=i+1;
        else
            stu[i].rank=stu[i-1].rank;
    }
    for(int i=0;i<n;i++){
        for(int j=0;j<k;j++){
            int sch=stu[i].choice[j];
            //当学生有‘无视剩余名额’录取资格或者学校本身还有名额时
            if(lastrank[sch]==stu[i].rank || quota[sch]>0){
                quota[sch]--;
                stu[i].res=sch;
                ans[sch].push_back(stu[i].id);
                lastrank[sch]=stu[i].rank;
                break;
            }
        }
    }
    for(int i=0;i<ans.size();i++){
        sort(ans[i].begin(),ans[i].end(),[](int &a,int &b)->bool{return a<b;});
        								//这种简单的cmp就用lambda表达式搞定 
        for(int j=0;j<ans[i].size();j++){
            if(j!=0) printf(" ");
            printf("%d",ans[i][j]);
        }
        printf("\n");
    }
    return 0;
}
发布了4 篇原创文章 · 获赞 0 · 访问量 44

猜你喜欢

转载自blog.csdn.net/qq_38399914/article/details/105587397