数论(整除分块) - Harmonic Number (II) - LightOJ 1245

数论(整除分块) - Harmonic Number (II) - LightOJ 1245

题意:
在这里插入图片描述
优化上面的函数。

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11
1
2
3
4
5
6
7
8
9
10
2147483647

Sample Output

Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386

分析:

在这里插入图片描述

n i 结论,对于\lfloor\frac{n}{i}\rfloor的求和,有

j = n n i 使 k [ i , j ] n k j=\lfloor\frac{n}{\lfloor\frac{n}{i}\rfloor}\rfloor,使得对任意的k∈[i,j],\lfloor\frac{n}{k}\rfloor恒定不变。

[ 1 , n ] i = 1 n n i O ( l n ( n ) ) 这样就能够将区间[1,n]分块处理,计算次数为\sum_{i=1}^n\frac{n}{i},时间复杂度O(ln(n))。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

#define ll long long

using namespace std;

ll H(int n)
{
    ll res=0;
    for(ll i=1,j;i<=n;i=j+1)
    {
        j=n/(n/i);
        res+=(ll)(n/i)*(j-i+1);
    }
    return res;
}

int main()     
{
    int T; cin>>T;
    for(int t=1;t<=T;t++)
    {
        int n; cin>>n;
        printf("Case %d: %lld\n",t,H(n));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/njuptACMcxk/article/details/107738887