ayit第十一周训练e题

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5
#include<stdio.h>
#include<string.h>
#include<math.h>
int e[100];
int main()
{
    int a,b,i,c,l;
    while(~scanf("%d %d %d",&a,&b,&c))
    {
        if(!a&&!b&&!c)
            break;
        e[1]=1;
        e[2]=1;
        for(i=3;i<=49;i++)
            e[i]=(a*e[i-1]+b*e[i-2])%7;
        l=e[c%49];
        printf("%d\n",l);
    }
    return 0;
}

题意   给你一个数n,让你求F(n),按照题目中的公式

思路   由斐波那契数列的性质,和斐波那契数列很像,可以使用矩阵快速幂来写

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/105903330