ayit第十二周训练d题

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO
#include<stdio.h>
int n,ll[220][210],h[220],w;
void dd()
{
    int f,i,j;
    while(1)
    {
        f=0;
        for(i=0;i<n;i++)
        {
            if(h[i]==0)
            {
                w++;
                h[i]=-1;
                f=1;
                for(j=0;j<n;j++)
                    if(ll[i][j])
                    h[j]--;
            }
        }
        if(f==0)
            break;
    }
}
int main()
{
    int m,i,j,x,y;
    while(~scanf("%d%d",&n,&m)&&(n+m)!=0)
    {
        w=0;
        memset(ll,0,sizeof(ll));
        memset(h,0,sizeof(h));
        for(i=1;i<=m;i++)
        {
            scanf("%d %d",&x,&y);
            if(!ll[x][y])
            {
                ll[x][y]=1;
                h[y]++;
            }
        }
        dd();
        if(w==n)
            printf("YES\n");
        else
           printf("NO\n");

    }
    return 0;
}

题型 拓扑排序

题意     在一个qq群里有着许多师徒关系,如A是B的师父,同时B是A的徒弟,一个师父也可能会有许多不同的师父。输入给出                  群里所有的师徒关系,问是否存在这样一种非法情况:以三人为例,即A是B的师父,B是C的师父,C又反过来是A的师               父

思路点之间相连形成了一个图每次找入度为0的点, 如果找到,入度减1,与之相连的点也相应-1,如果没找到,那么向 应图里面存在

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/106128963