PTA A+B and C (64bit) (20分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
n=eval(input())
k=0
while n:
    k=k+1
    n=n-1
    an=list(map(int, input().split(' ')))
    if an[0]+an[1]>an[2]:
        print("Case #{}: true".format(k))
    else:
        print("Case #{}: false".format(k))

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/108401950