【PAT甲级】1007 Maximum Subsequence Sum (25 分)

Maximum Subsequence Sum

题目描述

Given a sequence of K integers { N​1 , N​2, …, NK }. A continuous subsequence is defined to be { N​i​ , N​i+1​​ , …, Nj​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

使用在线处理算法,一次循环即可完成查找。
重点在于定义四个指针变量,其中两个记录上一个最大的子序列的首位索引,另外两个用于记录当前的窗口的首位索引

st:上一个最大子序列的头
ed:上一个最大子序列的尾
i:当前窗口的尾部
tep:当前窗口的头部

核心循环

int max=-1,cur=0;
while(i<K)
 {
    
    
    cur+=num[i];//记录当前窗口的和
    if(cur>max)//当前窗口的和比之前的大的时候,更新最大子序列
    {
    
    
        max=cur;
        ed=i;
        st=tep;
    }
    else if(cur<0)//当前窗口和小于0,证明前面的所有序列不存在作用,将当前窗口的头设为下一个值,当前和设为0
    {
    
    
        tep=i+1;
        cur=0;
    }
    i++;
}

注意题目有坑在于,如果全部是负数的情况,题目要求输出的是0,首,尾元素! 其他情况要求输入的也是最大子序列的首位值,而不是索引!

代码

#include<stdio.h>

#define MAXK 10001

int num[MAXK];

int main()
{
    
    
    int K;
    scanf("%d",&K);
    for(int i=0;i<K;i++)
        scanf("%d",&num[i]);
    int st=0,ed=0,i=0,tep=0;//record the start and end of subsequence,i is current point,tep is the temporary start
    int max=-1,cur=0;//define three point
    while(i<K)
    {
    
    
        cur+=num[i];
        if(cur>max)
        {
    
    
            max=cur;
            ed=i;
            st=tep;
        }
        else if(cur<0)
        {
    
    
            tep=i+1;
            cur=0;
        }
        i++;
    }
    if(max==-1)
    {
    
    
        max=0;st=0;ed=K-1;
    }
    printf("%d %d %d\n",max,num[st],num[ed]);
    return 0;
}

git仓库:Maximum Subsequence Sum

提示:

给出几个测试用例与正确结果

input:
10
-10 2 1 4 3 -5 -23 3 7 -3
output:
10 2 3
input:
10
-10 2 1 4 3 -5 -23 3 7 1
output:
11 3 1
input:
5
0 0 0 -1 -2
output:
0 0 0
input:
3
5 -5 5
output:
5 5 5
input:
5
-1 -2 -3 -5 -4
output:
0 -1 -4

猜你喜欢

转载自blog.csdn.net/qq_35779286/article/details/95385991