POJ - 2586 Y2K Accounting Bug(贪心)

                                         Y2K Accounting Bug

Time Limit: 1000MS   Memory Limit: 65536K

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

题意: 给你一个s,一个d。s代表某月盈利值,d代表某月亏损值。已知1-5,2-6 …… 8-12 连续五个月的总情况都为亏损,问是否可能盈利,若能最多可盈利多少。

解题思路:盈利最多即亏损的月份最少,即使得各段亏损的月份尽量相同(重叠)。

ACCode:

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
	int s,d,,ans;
	while(~scanf("%d%d",&s,&d)) {
		if(d >= 4*s) ans = 10*s - 2*d;
		else if(2*d >= 3*s) ans = 8*s - 4*d;
		else if(3*d >= 2*s) ans = 6*s - 6*d;
		else if(4*d >= s) ans = 3*s - 9*d;
		else ans = -1; //必定亏损
		if(ans >= 0)
			printf("%d\n",ans);
		else 
			printf("Deficit\n");
		/*
		123456789123
		ssssd
		 sssds
		  ssdss
		   sdsss
		    dssss
		     ssssd
		      sssds
		       ssdss
		sssdd
		 ssdds
		  sddss
		   ddsss
		    dsssd
		     sssdd
		      ssdds
		       sddss
		ssddd
		 sddds
		  dddss
		   ddssd
		    dssdd
		     ssddd
		      sddds
		       dddss
		sdddd
		 dddds
		  dddsd
		   ddsdd
		    dsddd
		     sdddd
		      dddds
		       dddsd

		*/
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/97645425