hdu 1049 Climbing Worm

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21540    Accepted Submission(s): 14783


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input

10 2 1

20 3 1

0 0 0

Sample Output

17

19

来到基础的数学题;这个之前就做过很多次,总是想的很慢。

一个数学公式就可以出来,我给他去个名字叫一步之遥。

#include<stdio.h>
int main()
{
	int n,u,d;
	while(~scanf("%d%d%d",&n,&u,&d),n)
	{
		int t=(n-u)/(u-d);//留一步
		if(t*(u-d)<(n-u))//留一步不够
		 t++;//再加一步
		t=t*2;
		t++;//一步之遥,就不用下降了
		printf("%d\n",t);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80158552