1049-Climbing Worm

Problem Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input

10 2 1
20 3 1
0 0 0

Sample Output

17
19

题目大概意思:有条虫子,想爬出一个高n英寸的洞,每秒爬u英寸,每爬完一秒就得歇一秒,又会掉下去d英寸,问需要多少时间才能爬出去

我的见解:n-u就是最后一爬之前需要的路程,u-d就是每两秒所爬的路程,作商就可以得到用了多少次两秒,因为最后一爬有可能不是刚刚好爬u英寸,所以得对商进行讨论

代码如下:

#include <iostream>
using namespace std;

int main()
{
	int n, u, d;
	while (cin >> n >> u >> d)
	{
		int t = 0;
		if (n == 0)return 0;
		if (((n - u) % (u - d)) == 0)
		{
			t = ((n - u) / (u - d)) * 2 + 1;
			cout << t << endl;
		}
		else 
		{
			t = ((n - u) / (u - d)+1) * 2 + 1;
			cout << t << endl;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43999137/article/details/84994358