小孩报数问题

题目描述

有N个小孩围成一圈,给他们从1开始依次编号,现指定从第W个开始报数,报到第S个时,该小孩出列,然后从下一个小孩开始报数,仍是报到S个出列,如此重复下去,直到所有的小孩都出列(总人数不足S个时将循环报数),求小孩出列的顺序。

输入

第一行输入小孩的人数N(N<=64) 
接下来每行输入一个小孩的名字(人名不超过15个字符) 
最后一行输入W,S (W < N),用逗号","间隔

输出

按人名输出小孩按顺序出列的顺序,每行输出一个人名

样例输入

5
Xiaoming
Xiaohua
Xiaowang
Zhangsan
Lisi
2,3

样例输出

Zhangsan
Xiaohua
Xiaoming
Xiaowang
Lisi
#include<iostream>
#include<string>
using namespace std;
int main()
{
      struct  child
      {
            string name;
            child *next;
      };
    int count,start,m;
    char ch;
    cin>>count;
    child *head = NULL;
    head = new child;
      cin>>head->name;

    child *p = head;
    for(int i = 0; i <count - 1; i++)
      {
    p->next = new child;
    p=p->next;
    cin>>p->name;
    }
     p->next = head;
    cin >> start>>ch>>m;

    for(int i = 1; i < start; i++)
    head = head->next;

    while(head->next != head){
    child *father=NULL;
    for(int i = 1; i < m; i++){
        father = head;
        head = head->next;
    }

   father->next = head->next;
    cout << head->name << endl;
    delete head;
    head = father->next;

    }
    cout << head->name << endl;
    delete head;
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/i_silence/article/details/80496197