A1063 Set Similarity

  1. 题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%
  1. 问题分析

  • Nc = A∩B

  • 枚举看有几个相等---->尽量使用find,否则容易超时

  • Nt = AUB

  • insert一下

  1. 代码

此代码最后一个测试用例会超时,即使换成unordered_set也不行,

应该是在的求交集部分

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <unordered_set>
using namespace std;
int NC(unordered_set<int> a,unordered_set<int> b)
{
    int nc=0;
    for(auto ait :a)
    {
        for(auto bit:b)
        {
            if(ait==bit)
            {
                nc++;
            }
        }
    }
    return nc;
}
int NT(unordered_set<int> a,unordered_set<int> b)
{
   for(auto bit:b)
   {
       a.insert(bit);
   }
    return a.size();
}
double Simliarity(unordered_set<int> a,unordered_set<int> b)
{

    return NC(a,b)*1.0/NT(a,b);
}
int main() {
    int setnum,querynum;
    scanf("%d",&setnum);
    unordered_set<int>   sets[setnum];
     int numinset;
     int num;
     for(int i=0;i<setnum;i++)
     {
         scanf("%d",&numinset);
         for(int j=0;j<numinset;j++)
         {
             scanf("%d",&num);
             sets[i].insert(num);
         }
     }

    scanf("%d",&querynum);

     int set1,set2;
     double sim=-1;
     for(int i=0;i<querynum;i++)
     {
         scanf("%d %d",&set1,&set2);
         sim = Simliarity(sets[set1-1],sets[set2-1]);
         printf("%.1f%\n",sim*100);
     }
    return 0;
}

3.1 不超时的代码

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <unordered_set>
using namespace std;
void Simliarity(unordered_set<int> a,unordered_set<int> b)
{
    int nc=0;


    for(auto ait :a)
    {
         if(b.find(ait)!=b.end())
         {
             nc++;
         }
    }
    for(auto ait :a)
    {
         b.insert(ait);
    }
    int nt = b.size();
    printf("%.1f%\n",nc*1.0/nt*100);


}

int main() {
    int setnum,querynum;
    scanf("%d",&setnum);
    unordered_set<int>   sets[setnum];
     int numinset;
     int num;
     for(int i=0;i<setnum;i++)
     {
         scanf("%d",&numinset);
         for(int j=0;j<numinset;j++)
         {
             scanf("%d",&num);
             sets[i].insert(num);
         }
     }

    scanf("%d",&querynum);

     int set1,set2;

     for(int i=0;i<querynum;i++)
     {
         scanf("%d %d",&set1,&set2);
         Simliarity(sets[set1-1],sets[set2-1]);

     }
    return 0;
}
  1. 收获与思考

  • 两个集合求交集 使用find

    扫描二维码关注公众号,回复: 15361723 查看本文章
  • for(auto it: set) it 是个数

  • 一定注意是从0开始还是从1开始

猜你喜欢

转载自blog.csdn.net/weixin_45621688/article/details/129407907