PAT A1063 Set Similarity+Set初探

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

代码:

#include <iostream>
#include <set>

using namespace std;

const int maxn=55;

set<int> st[maxn];

void printSimilarity(int x,int y){
    int a=st[x].size(),b=st[y].size();
    int sameNum=0;

    for(set<int>::iterator it=st[y].begin();it!=st[y].end();it++){ //遍历y集合
        if(st[x].find(*it)!=st[x].end()){   //x集合找到y的元素
            sameNum++;
        }
    }
    printf("%.1f%%\n",sameNum*100.0/(a+b-sameNum)); //注意百分号%的打印需要通过转义%%
}
int main()
{
    int n,m,num,k;
    cin >> n;
    for(int i=0;i<n;i++){
        scanf("%d",&m);
        for(int j=0;j<m;j++){
            scanf("%d",&num);
            st[i].insert(num);
        }
    }
    cin >> k;
    int x,y;
    for(int i=0;i<k;i++){
        scanf("%d%d",&x,&y);
        printSimilarity(x-1,y-1); //x,y是以1开始的
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/88094751