贪心算法巩固

问题

1067 Sort with Swap(0, i) (25 分)
Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (≤10
5
) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
结尾无空行
Sample Output:
9

思路

利用数组存储数据,num[temp]表示数temp所在的位置。记录下不在本位的元素个数,只要不为0就一直循环交换。

代码

#include<bits/stdc++.h>
using namespace std;
int num[100010];

int main(){
    
    
    int n,temp,ans=0;
    cin>>n;
    int left=n-1;
    for (int i = 0; i < n; ++i) {
    
    
        cin>>temp;
        num[temp] = i;
        if(temp==i && i!=0)
            --left;
    }
    int k = 1;
    while (left>0){
    
    
        if(num[0]==0){
    
     //0在本位上,则与最小的不在本位上的元素交换
            while(k<n){
    
    
                if(num[k]!=k){
    
    
                    ans++;
                    swap(num[0],num[k]);
                    break;
                }
                k++;
            }
        }
        while(num[0]!=0){
    
    
            swap(num[0],num[num[0]]);
            left--;
            ans++;
        }
    }

    cout<<ans;
    return 0;
}

总结

此题不能使用vector。因为数组长度已经达到了100000,使用vector会发生段错误。

猜你喜欢

转载自blog.csdn.net/qq_19272233/article/details/119429042