2883: 闰年判断

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 124   Solved: 68
[ Submit][ Status][ Web Board]

Description

定义一个函数leapyear,函数声明如下:


int leapyear(int n);   
//函数声明,如果参数n是闰年返回1,不是闰年返回0


在下面代码的基础上完成,提交时只提交leapyear的函数定义


#include <iostream>
using namespace std;
 
int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
int main()
{
   int year;
   cin>>year;  
   if( leapyear(year)==1 )
      cout<<"leapyear"<<endl;
   else
      cout<<"not leapyear"<<endl;   
   return 0;
}

Input

Output

如果输入的年是闰年输出leapyear,如果不是闰年输出not leapyear

Sample Input

2000

Sample Output

leapyear

HINT

提交时只提交leapyear的函数定义

Source

gyy



代码:



#include <iostream>
 using namespace std;
  
 int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
 int main()
 {
    int year;
    cin>>year;   
    if( leapyear(year)==1 )
       cout<<"leapyear"<<endl;
    else
       cout<<"not leapyear"<<endl;    
    return 0;
 }
  int leapyear(int n)
  {
  if((n%4==0&&n%100!=0)||(n%400==0))
  return 1;
  else return 0;
  }

猜你喜欢

转载自blog.csdn.net/qq_41170600/article/details/79829904