简单枚举类型——植物与颜色

简单枚举类型——植物与颜色

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 

Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 

Sample Input

blue
yellow
purple

Sample Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.
 
  
package hello;
import java.util.Scanner;
enum Color{
	red("Rose", "red"),                      //建立对应的枚举类型
	orange("Poppies", "orange"), 
	yellow("Sunflower","yellow"), 
	green("Grass", "green"), 
	blue("Bluebells", "blue"), 
	violet("Violets", "violet");
	
	String name;
	String color;
	
	Color(String name, String color){    //构造方法
		this.name = name;
		this.color = color;
	}
	public String toString() {          //重写toSting方法
		return name+" are "+color+".";
	}
}
public class Main {  
   
    public static void main(String[] args) {  
        Scanner cin = new Scanner(System.in);  
        int flag = 1;
        while(cin.hasNext()) {
        	String incolor = cin.next();
        	/*Color color = Color.valueOf(incolor);     //本来想通过转化之后判断一个该颜色有没有在枚举序列中,当时如果没在序列中
        	for(Color a:color.values()) {           //valueOf函数就会抛出异常,程序没法执行,所以用try来实现
        		if(a.equals(color)) {
        			flag = 0;
        			break;
        		}
        	}
        	if(flag == 0) {
        		System.out.println(color);
        	}
        	else {
        		System.out.println("I don't know about the color "+incolor+".");
        	}*/
        	try{                             //如果输入的颜色不在对应的颜色序列当中,就会抛出异常
				Color color = Color.valueOf(incolor);
				System.out.println(color);
			}
			catch(Exception e){
				System.out.println("I don't know about the color "+incolor+".");
			}
        }
        cin.close();
    }  
}  


猜你喜欢

转载自blog.csdn.net/horizonhui/article/details/79645679