[反转(开关问题)] Fliptile POJ3279

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15259   Accepted: 5610

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source



/// 反转顺序无影响
// O(mn * (2 ^ n))
#include <iostream>
#include <cstring>
using namespace std;

const int inf = 0x7fffffff;
const int mm = 15, mn = 15;

int m, n;
int mp[mm][mn], t[mm][mn], e[mm][mn];
int x[5] = {-1, 0, 0, 0, 1};
int y[5] = {0, -1, 0, 1, 0};

int get(int i, int j)  // 查询 [i, j] 的颜色
{
	int s = mp[i][j];
	for (int e = 0; e < 5; e++)  // 邻接的五个格子
	{
		int tx = i + x[e];
		int ty = j + y[e];
		if (tx >= 0 && tx < m && ty >= 0 && ty < n)
			s += t[tx][ty];
	}
	return s % 2;
}

int fan()
{
	for (int i = 1; i < m; i++)
	{
		for (int j = 0; j < n; j++)
		{
			if (get(i - 1, j) != 0)  // 前一行的这一位为黑色 需反转
				t[i][j] = 1;
		}
	}
	for (int j = 0; j < n; j++)  // 最后一行有黑色块 方法不存在
		if (get(m - 1, j) != 0)
		return -1;
	
	int res = 0;
	for (int i = 0; i < m; i++)
		for (int j = 0; j < n; j++)
		res += t[i][j];
	return res;
}

int main()
{
	cin >> m >> n;
	for (int i = 0; i < m; i++)
		for (int j = 0; j < n; j++)
		cin >> mp[i][j];
		
	int res = inf;
	for (int i = 0; i < 1 << n; i++) // 二进制枚举第一行的可能性
	{
		memset(t, 0, sizeof t);
		
		for (int j = 0; j < n; j++)
			t[0][n - j - 1] = (i >> j) & 1; // i 时 第0行的情况
			
		int num = fan();
		
		if (num > 0 && num < res)
		{
			res = num;
			for (int i = 0; i < m; i++)
				for (int j = 0; j < n; j++)
				e[i][j] = t[i][j];
		}
	}
	
	if (res == inf)
		cout << "IMPOSSIBLE" << endl;
	else 
	{
		for (int i = 0; i < m; i++)
		{
			for (int j = 0; j < n; j++)
				cout<< e[i][j] << ' ';
			cout << endl;
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80976516