zoj-3872——Beauty of Array

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output
For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38
题意概括:
给n个数,有重复的,问所有的子序列的和为多少(每个序列中重复的只计算一次)。画的太糙,用鼠标写的不溜,先看看吧,,,
这里写图片描述
这里写图片描述

#include<stdio.h>
#include<string.h>

#define N 100010
#define LL long long

LL a[N],vis[N];
LL b[1000000];

int main()
{
    int i, j, k, n, T;
    LL sum;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        memset(b, 0, sizeof(b));
        memset(vis,0,sizeof(vis));
        k=n;
        for(i = 1; i <= n; i++){
            scanf("%lld", &a[i]);
            vis[i]=a[i]*(k--);//k为在这一次以a[1]为首项的排列中a[i]要出现的次数 
        }
        sum=0;
        for(i = 1; i <= n; i++)
        {
           if(!b[a[i]])
              sum+=vis[i]*i;
           else
              sum+=vis[i]*(i-b[a[i]]);//(i-b[a[i]]),b[a[i]]为前一个a[i]在这一次排列中能排到的位置,所以(i-b[a[i]])w为剩下的这种排列的次数 
             b[a[i]]=i;
        }
        printf("%lld\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/watestill/article/details/80144193