ZOJ - 3872 Beauty of Array dp

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

题意:给出n个数字的序列,求所有连续的子序列,不同数字的和。

题解:我们求出每个位置的数会在多少个子序列中出现即可,假设第k个数a[k],他出现的子序列的数量为 k*(n+1-k),但是,有一样的数,比如对应p(p<k) 的位置a[p]==a[k] ,对应k位置的我们只计算(k-p)*(n+1-k)即可,因为p和p之前的,在计算p的时候已经计算了一遍了,计算p:p*(n+1-p),因此计算k这个位置时,如果把p之前的序列在算上,那么a[k]在一个序列中就计算两遍了,所以标记一下当前数前面出现的位置,对于每个

位置k,a[k],计算(i - pre[a[k] ]) * (n + 1 - i) * a[k] 即可

扫描二维码关注公众号,回复: 4287186 查看本文章
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
const int N=1e5+10;
int n,pre[N*10]; 
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		ll ans=0,x;
		scanf("%d",&n);
		memset(pre,0,sizeof(pre));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			ans+=(ll)x*(i-pre[x])*(n+1-i);
			pre[x]=i;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/84617948