map操作---E - Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

大概意思是,每一轮N个输入气球的颜色,输出数量最多的那种颜色的气球的颜色,0表示结束输入。

使用map操作,存储和输出,代码如下:

#include<iostream>
#include<string>
#include<map>
using namespace std;

int main(){
    map<string,int>Q;
    int N = 1;
    string s[1005];
    while(N){
        cin >> N;
        if(N == 0)
            return 0;
        for(int i = 0;i < N;i++){
            cin >> s[i];
            Q[s[i]]++;
        }
        map<string,int>::iterator it;
        int max = 0;
        string s ="";
        for(it=Q.begin();it!=Q.end();it++){
            if(it->second > max){
                s = it->first;
                max = it->second;
            }
        }
        cout << s << endl;
        Q.clear();
    }
    return 0;
}

结果:


猜你喜欢

转载自blog.csdn.net/sunshine_0880/article/details/80752030