Let the Balloon Rise —— map映照容器

问题:

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题意:

给你多种颜色,让你输出颜色出现次数最多的。

思路:

统计每种颜色出现的次数,输出最多的。

代码:

#include<map>
#include<string>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        map<string,int>m;         
        char s[20],k[20];
        int max=0;
        for(int i=0; i<n; i++)
        {
            scanf("%s",s);
            if(m.find(s)==m.end())//如果这种颜色第一次出现,出现次数为一
                m[s]=1;
            else                  //不是第一次出现,出现次数加一
                m[s]++;
            if(m[s]>max)          //保留出现次数最多的
            {
                max=m[s];
                strcpy(k,s);
            }
        }
        printf("%s\n",k);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lxxdong/article/details/81108615