【带权并查集】[kuangbin带你飞]专题五 并查集 J - A Bug's Life

J - A Bug's Life

 

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.

//pre【2*n】 前n个和后n个对应为异性
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=2e4+5;
int pre[maxn<<1],n,m; //因为前n个记录实际,后n个记录与实际相反,所以要2n的数组

int find(int x)
{
    if(pre[x]<0) return x;   //要是没有祖先,直接返回x
    if(x!=pre[x]) pre[x]=find(pre[x]);  //普通路径压缩
    return pre[x];
}

void join(int x,int y)
{
    int fx=find(x),fy=find(y);   //要是祖先不同,就更新祖先
    if(fx!=fy) pre[fx]=fy;
}

int main()
{
    int t,tot=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(pre,-1,sizeof(pre));
        int flag=0;
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(!flag)
            {
                join(x,y+n);  //因为x与y配对,那么x与y为异性
                join(y,x+n);  //x与x+n为异性,y与y+n为异性,所以x与y+n为同性
                if(find(x)==find(x+n)||find(y)==find(y+n)) flag=1;  //要是矛盾了,就是同性恋
            }
        }
        if(!flag) printf("Scenario #%d:\nNo suspicious bugs found!\n\n",tot++);
        else printf("Scenario #%d:\nSuspicious bugs found!\n\n",tot++);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81062615