Aggressive cows(二分最大最小问题)

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题目大意:n个牛栏位置,c头牛。求出每头牛之间的距离最大的最小值。

思路:数据非常大,暴力是完全不可能的。使用二分,感觉二分对于这道题来说是一种优化。我的做法是二分枚举每头牛之间的最大距离,枚举每头牛,如果不能放下或能放下,就二分缩小范围。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 100000
#define INF 1000000000
int n,m;
int a[maxn];
int C(int d)//判断是否满足条件 
{
    int last=0;
    for(int i=1;i<m;i++)//m头牛遍历 
    {
        int crt=last+1;
        while(crt<n&&a[crt]-a[last]<d)//当前位置与上一个位置的距离小于d时执行 
        {
            crt++;
        } 
        if(crt==n)//若执行到最后则满足条件 
        return 0;
        last=crt;//记录位置 
    }
    return 1;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    scanf("%d",&a[i]);
    sort(a,a+n);//将牛舍位置排序 
    int z=0,y=INF;//初始化解的存在范围 
    while(y-z>1)
    {
        int mid=(z+y)/2;
        if(C(mid)==1)
            z=mid;
        else
            y=mid;
    }
    printf("%d\n",z);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/pleasantly1/article/details/81035287