hdu 1595 find the longest of the shortest(Dijkstra+枚举)

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output

11
13
27

思路:先用Djikstra算一遍最短路,记录最短路走过的路径,枚举路径,找到路径损坏时最长的一条。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 1010
using namespace std;
int ma[M][M],dis[M],vis[M],pail[M],pailx[M],paily[M];
int n,m;
void init()
{
    memset(ma,0x3f,sizeof(ma));
    for(int i=1;i<=n;i++)
        ma[i][i]=0;
}
int dijskl(int pp)
{
    memset(dis,0x3f,sizeof(dis));
    memset(vis,0,sizeof(vis));
    dis[1]=0;
    int k,pan;
    for(int i=0;i<=n;i++)
    {
        pan=0x3f3f3f;
        k=0;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]<pan&&!vis[i])
            {
                pan=dis[i];
                k=i;
            }
        }
        if(!k)
            break;
        vis[k]=1;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]>ma[k][i]+dis[k])
            {
                dis[i]=dis[k]+ma[k][i];
                if(pp)
                {
                    pail[i]=k;
                    pailx[i]=k;
                    paily[i]=i;
                }
            }
        }
    }
    return dis[n];
}
int main()
{
    int x,y,v,ans;
    while(~scanf("%d%d",&n,&m))
    {
        ans=0;
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&v);
            if(ma[x][y]>v)
            {
                ma[x][y]=v;
                ma[y][x]=v;
            }
        }
        memset(pail,0,sizeof(pail));
        dijskl(1);
        int k,rema;
        k=n;
        while(k!=1)
        {
            x=pailx[k];
            y=paily[k];

            rema=ma[x][y];
            ma[x][y]=0x3f3f3f;
            ans=max(ans,dijskl(0));
            ma[x][y]=rema;
            k=pail[k];
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/81094537