HDU2136 Largest prime factor(最大素数位置)

Problem Description

Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input

Each line will contain one integer n(0 < n < 1000000).

Output

Output the LPF(n).

Sample Input

1 2 3 4 5

Sample Output

0 1 2 1 3

#include<bits/stdc++.h>
int a[1000001];
int main(){
	int cnt=1;
	memset(a,0,sizeof(a));
	for(int i=2;i<1000001;i++)
	{
		if(a[i]==0)
		{
			a[i]=cnt;
			for(int k=2*i;k<1000001;k+=i)
			{
				a[k]=cnt;
			}
			cnt++;
		}
	}
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",a[n]);
	 } 
	 return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/81169129