Largest prime factor@HDU 2136

Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input

Each line will contain one integer n(0 < n < 1000000).

Output

Output the LPF(n).

Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3

题目分析:求一个数的最大质因子的位置,采用打表的方式,除质数外,每个数的值是不断被更新的,更新后的值是这个数的最大质因子的位置。

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cstdio>
#include <stack>
#include <deque>
#include <set>
#include <cmath>
#include <map>
#define MAXN 1000003
#define INF 0x3f3f3f3f
using namespace std;

int prime[MAXN];

void init(){
    memset(prime,0,sizeof(prime));
    int pos = 0;
    prime[0] = 0;
    prime[1] = 0;
    for(int i=2;i<MAXN;++i){
        if(prime[i] == 0){
            prime[i] = ++pos;
            for(int j=2;i*j<MAXN;++j){
                prime[j*i] = pos;
            }
        }
    }
}

int main(){
    init();
    int n;
    while(~scanf("%d",&n)){
        if(n == 1) cout << 0 << endl;
        else cout << prime[n] << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39021458/article/details/81407399