hdu1008-Elevator电梯,水题,要正确理解题意

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 82776    Accepted Submission(s): 45397


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
 
  
1 2 3 2 3 1 0
 

Sample Output
 
  
17 41

关键就是正确理解题意,意思就是上一层需要6分钟,下一层需要4分钟,让你按照给出的顺序到达每一站,并在这些站停5分钟,注意不是每一站都停五分钟,而是在人家给出的列表上的站停5分钟

题意理解了做题就不是问题

代码;

#include <stdio.h>
int main()
{
    int n,i,j,t,p;
    while(~scanf("%d",&n)&&n)
    {
        p=0;
        t=0;
        int a[10000];
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        for(i=0;i<n;i++)
        {
            if(a[i]==p)
                t=t+5;
            if(a[i]>p)
            {
                t=t+(a[i]-p)*6+5;
                p=a[i];
            }
            if(a[i]<p)
            {
                t=t+(p-a[i])*4+5;
                p=a[i];
            }
        }
        printf("%d\n",t);
    }
    return 0;
}

还有一个地方需要注意一下,就是一开始代码写的是输入n,然后定义一个a[n],但是提交不过,显示编译错误,要求定义的数组里应该是一个常数。就改成了定义为a【10000】。。。

猜你喜欢

转载自blog.csdn.net/nanfengzhiwoxin/article/details/80587020