HDU2553还是畅通工程(最小生成树)

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56089    Accepted Submission(s): 25448


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
 
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
 
  
3 5

思路:明显的最小生成树,这里采用kruskal算法

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int f[105];
struct road
{
 int l,r,cost;
}num[5000];
bool cmp(road x,road y)
{
 return x.cost < y.cost;
}
int find(int x)
{
 if (x != f[x])
  f[x] = find(f[x]);
 return f[x];
}
void join(int x,int y)
{
 int fx = find(x),fy = find(y);
 if (fx != fy)
  f[fx] = fy;
}
int main()
{
 int n,i;
 while (~scanf("%d",&n) && n)
 {
  for (i = 1;i <= n;i ++)
   f[i] = i;
  int ty = n * (n - 1) / 2,ans = 0,cnt = 0;
  for (i = 0;i < ty;i ++)
   scanf("%d %d %d",&num[i].l,&num[i].r,&num[i].cost);
  sort(num,num + ty,cmp);
  for (i = 0;i <= ty;i ++)
  {
   if (find(num[i].l) != find(num[i].r))
    ans += num[i].cost,join(num[i].l,num[i].r),cnt ++;
   if (cnt == n - 1) break;
  }
  printf("%d\n",ans);
 }
 return 0;
 }

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/80643614