hdu1520(树形DP入门)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16686    Accepted Submission(s): 6344


 

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

 

Output

Output should contain the maximal sum of guests' ratings.

 

Sample Input

 

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

 

Sample Output

 

5

 

Source

Ural State University Internal Contest October'2000 Students Session

树形dp的常规入门题:设dp[i][0]表示:当前这个点不选,dp[i][1]表示当前这个点选择的最优解。

转移方程:dp[cur][0]+=max(dp[son][1],dp[son][0]);//当前这个点不选,那他的孩子可选可不选,取 
最大的。 
dp[cur][1]+=dp[son][0]//当前这点选择,那他的孩子就不能选择。

#include <bits/stdc++.h>
using namespace std;
const int N = 6005;

int happy[N], dp[N][2], f[N], n;

vector<int> E[N];

void dfs(int cur)
{
    dp[cur][1] = happy[cur];

    for(int i = 0;i < E[cur].size();i ++)
    {
        int son = E[cur][i];
        dfs(son);

        dp[cur][0] += max(dp[son][0],dp[son][1]);
        dp[cur][1] += dp[son][0];
    }
}

int main()
{

    while(~scanf("%d",&n))
    {
        for(int i = 1;i <= n;i ++)
        {
            cin >> happy[i];
            E[i].clear();

            dp[i][0] = dp[i][1] = 0;
            f[i] = -1;
        }
        int a, b;
        while(scanf("%d%d",&a,&b) && a != 0 && b != 0)
        {
            E[b].push_back(a);
            f[a] = b;
        }

        int t = 1;
        while(f[t] != -1)
            t = f[t];

        dfs(t);

        cout << max(dp[t][1], dp[t][0]) << '\n';
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81456654