POJ1976

A Mini Locomotive

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3188   Accepted: 1736

Description

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the ith number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240

Source

Tehran Sharif 2004 Preliminary

有点01背包的意思

原来是一个物品取还是不取  现在变成了连续的k节车厢拿走还是不拿走,  我们可以用数组处理这些数据 

使之变成每k给连在一起   取的话就减去k个  再加上对应  这k个的人数  

#include <bits/stdc++.h>
using namespace std;
const int N = 50005;
int a[N], b[N], dp[4][N];
int n, k;
int main()
{
    int T;
    cin >> T;
    while(T --)
    {
        cin >> n;
        a[0] = 0;
        b[0] = 0;
        for(int i = 1;i <= n;i ++)
        {
            cin >> a[i];
            b[i] = b[i - 1] + a[i];  //只需要算到k就可以了   省个循环直接放这里面了
        }

        memset(dp,0,sizeof(dp));

        cin >> k;

        int sum = b[k];

        for(int i = k + 1;i <= n;i ++)
        {
            sum += a[i];  //加上新一节的车厢
            sum -= a[i - k]; //减去最前面的车箱

            b[i] = sum;  //记录连续k节的车箱人数信息
        }

        for(int i = 1;i <= 3;i ++)
        {
            for(int j = k;j <= n;j ++)
            {
                dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - k] + b[j]);
            }
        }
        cout << dp[3][n] << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81431655
POJ