Palindrome POJ - 1159

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

/*
题意·:最少插入多少个字符使得原来的字符串变成回文
思路
设原序列S的逆序列为S' ,则最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子序列长度
代码:
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[5100],s2[5100];
int dp[3][5100];
int main()
{
    int n;
    int i,j;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        scanf("%s",s1);
        j=0;
        for(i=n-1;i>=0;--i)
            s2[j++]=s1[i];
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=n;++j)
            {
                if(s1[i-1]==s2[j-1])
                {
                    dp[i%2][j]=dp[(i-1)%2][j-1]+1;
                }
                else
                    dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
            }
        }
        printf("%d\n",n-dp[n%2][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Qtt110/article/details/81365267