POJ1159(Palindrome)

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 56745   Accepted: 19626

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
题意:对给定的字符串在任意进行插入任意字符操作,使其在最小操作次数成为回文串。输出最小操作数。


思路:如果是回文串,其正序逆序相同,那么只要对给定的字符串正序序列和逆序序列求LCS,可以得到当前字符串正序序列和逆序序列最大的相同部分,即最大的回文部分,其余部分均无回文。那么还需在对应位置插入与无回文部分的字符相同的字符,使之回文。答案即是无回文部分字符的个数。

注意到数据范围5000较大,5000*5000会MLE。

优化1:可以用滚动数组优化空间

优化2:或者将dp数组的数据类型改成short int (即short dp[5005][5005]),此题亦可过(水水更健康=.=)

#include<cstdio>
#include<cstring>
#define max(a,b) (a)>(b)?(a):(b)
char a[5005],b[5005];
int dp[2][5005];
int main(){
    int n;
    while(~scanf("%d",&n)){
        memset(dp,0,sizeof(dp));
        getchar();
        for(int i = 0; i < n; i++){
            scanf("%c",&a[i]);
            b[n-i-1]=a[i];
        }
        int now=0,pre=1;
        for(int i = 0; i < n; i++){
            pre^=1;
            now^=1;
            for(int j = 0; j < n; j++){
                if(a[i]==b[j])
                dp[now][j]=max(dp[pre][j],dp[pre][j-1]+1);
                else
                    dp[now][j]=max(dp[pre][j],dp[now][j-1]);
            }
        }
        printf("%d\n",n-dp[now][n-1]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/Mad_boys/article/details/47982341