POJ 2774 Long Long Message(后缀数组)

POJ 2774 Long Long Message(后缀数组)

Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 34218 Accepted: 13732
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother.
The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out:

  1. All characters in messages are lowercase Latin letters, without punctuations and spaces.
  2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long.
  3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer.

E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc.

  1. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different.

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat.
Background:
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be.
Why ask you to write a program? There are four resions:

  1. The little cat is so busy these days with physics lessons;
  2. The little cat wants to keep what he said to his mother seceret;
  3. POJ is such a great Online Judge;
  4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :(

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

题意

  求两个字符串的最长公共子串。

解题思路

  直接枚举肯定会TLE。后缀数组有个特性,即对于原字符串的任意子串,该子串一定是某一个后缀的前缀。知道这个特性,我们就可以把题目的问题转换为求这两个子串后缀数组最大公共前缀。我们先把两个串接起来,求一次sa和height。height[i]表示的是两个字典序相邻的最长前缀,但我们这里又不能直接找最大的height[i],因为相邻两个子串可能来自于同一个原串,所以在枚举的时候需要判断相邻的两个sa是否来自于两个不同的串,这样直接通过值判断就行了,最后我们得到的就是max(height[i]&&sa来自于两个串),即为答案。

代码

#include <cstdio>
#include <iostream>
#include <cstring>
#define  LL long long
#define  ULL unsigned long long
using namespace std;
const int maxn= 2e5+50;

int wa[maxn],wb[maxn],wv[maxn],wt[maxn];

int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(char r[],int sa[],int n,int m)
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0; i<m; i++) wt[i]=0;
    for(i=0; i<n; i++) wt[x[i]=r[i]]++;
    for(i=1; i<m; i++) wt[i]+=wt[i-1];
    for(i=n-1; i>=0; i--) sa[--wt[x[i]]]=i;
    for(j=1,p=1; p<n; j*=2,m=p)
    {
        for(p=0,i=n-j; i<n; i++) y[p++]=i;
        for(i=0; i<n; i++) if(sa[i]>=j) y[p++]=sa[i]-j;
        for(i=0; i<n; i++) wv[i]=x[y[i]];
        for(i=0; i<m; i++) wt[i]=0;
        for(i=0; i<n; i++) wt[wv[i]]++;
        for(i=1; i<m; i++) wt[i]+=wt[i-1];
        for(i=n-1; i>=0; i--) sa[--wt[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
    return;
}
int sa[maxn],rankk[maxn],height[maxn],n;

void getheight(char *r,int *sa,int n)
{
    int i,j,k=0;
    for(i=1; i<=n; i++) rankk[sa[i]]=i;
    for(i=0; i<n; height[rankk[i++]]=k)
        for(k?k--:0,j=sa[rankk[i]-1]; r[i+k]==r[j+k]; k++);
    for(int i=n; i>=1; --i) ++sa[i],rankk[i]=rankk[i-1];
}

char arr[maxn],str1[maxn],str2[maxn];
int main()
{
#ifdef DEBUG
    freopen("in.txt","r",stdin);
#endif // DEBUG
    scanf("%s%s",str1,str2);
    int len1=strlen(str1),len2=strlen(str2),len=len1+len2;
    for(int i=0;i<len1;i++)
        arr[i]=str1[i];
    for(int i=len1;i<len;i++)
        arr[i]=str2[i-len1];
    arr[len1+len2]='\0';
    da(arr,sa,len+1,200);
    getheight(arr,sa,len);
    int ans=0;
    for(int i=2;i<=len;i++)
    {
        if(sa[i]>=1&&sa[i]<=len1&&sa[i-1]>len1) ans=max(ans,height[i]);
        if(sa[i]>len1&&sa[i-1]>=1&&sa[i-1]<=len1) ans=max(ans,height[i]);
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36258516/article/details/81408038