I Hate It +线段树

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 98898    Accepted Submission(s): 37261


 

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

 

Output

对于每一次询问操作,在一行里面输出最高成绩。

 

Sample Input

 

5 6

1 2 3 4 5

Q 1 5

U 3 6

Q 3 4

Q 4 5

U 2 9

Q 1 5

 

Sample Output

 

5

6

5

9

在成功的路上了!!!加油

AC代码:

#include <bits/stdc++.h>
using namespace std;
const int  MAXN = 1<<19;
const int MAXu = 2e6+10;

int father[MAXu];
struct node{
    int value;
    int left;
    int right;
}tree[MAXN];
void BuildTree(int i,int left,int right){ //建树,从上往下建
    tree[i].left = left;
    tree[i].right = right;
    tree[i].value = 0;
    if(left == right){
        father[left] = i;
        return ;
    }
    BuildTree((i<<1),left,(int)(floor(left+right)/2.0)); //左树
    BuildTree((i<<1)+1,(int)(floor(left+right)/2.0)+1,right);//右树
}

void UpdateTree(int tr){
    if(tr == 1){   // 等于根退出操作 ,自底向上更新
        return ;
    }
    int fa = tr/2;
    int a = tree[fa<<1].value; // 父节点的左子树的最大值
    int b = tree[(fa<<1)+1].value; //父节点的右子树的最大值 << 优先级小于+
    tree[fa].value = max(a,b);
    UpdateTree(tr/2);
}

int Maxt;
void Query(int i,int l,int r){  //查找
    if(tree[i].left == l && tree[i].right == r){
        Maxt = max(Maxt,tree[i].value); 
        return ;
    }
    i = (i<<1);
    if(l <= tree[i].right){    //还是有点没明白
        if(r <= tree[i].right) Query(i,l,r);
        else Query(i,l,tree[i].right);
    }
    i++;
    if(r >= tree[i].left){
        if(l >= tree[i].left) Query(i,l,r);
        else Query(i,tree[i].left,r);
    }
}

int main()
{
    int n,m,g;
    int a,b;
    char ch;
    while(scanf("%d%d",&n,&m)==2){
        BuildTree(1,1,n);
        for(int i=1;i<=n;i++){
            scanf("%d",&g);
            tree[father[i]].value = g;
            UpdateTree(father[i]);
        }
       while(m--){
            getchar();
             scanf("%c%d%d",&ch,&a,&b);
            if(ch=='Q'){  
                Maxt = 0; //初始化最大值
                Query(1,a,b); //进行查找
                printf("%d\n",Maxt);
            }
            else{
                tree[father[a]].value = b;
                UpdateTree(father[a]); //更新
                }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/blackneed/article/details/81319685