求解N的阶乘法在k进制下的位数

Description
Factorial of an integer is defined by the following function
f(0) = 1
f(n) = f(n - 1) * n, if(n > 0)
So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.
In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.
Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.
Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.
Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.
Sample Input
5
5 10
8 10
22 3
1000000 2
0 100
Sample Output
Case 1: 3
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1

用换底公式去做即可,这样也能方便预处理节省时间。

logk( n! ) = log( n! ) / log( k )

#include<iostream>
#include<cmath>
#define maxn 1000005
using namespace std;
double ans,tmp;
double A[maxn];
void db(){
    A[0]=log(1);
    for(int i=1;i<=maxn;i++){
        A[i]=A[i-1]+log(i);
    }
}
int main(){
    int n,k;
    db();
    cin>>n>>k;
    ans=A[n]/log(k)+1;
    cout<<(int)ans<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37360631/article/details/81488688