hdu primes hdu2161

Primes

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15947 Accepted Submission(s): 6474

Problem Description

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by “yes” or “no”.

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes
#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <vector>
#include <map>
#define maxn 10000
using namespace std;
int pri[16005];
void prime(){
    memset(pri,1,sizeof pri);
    pri[1]=0;pri[2]=0;pri[3]=1;
    for(int k=3;k<=16000;k++){
        for(int i=2;i<=sqrt(k);i++){
            if(!(k%i)){
               pri[k]=0;
                break;
            }
        }
    }
}
int main(){
    int t = 1;
    prime();
    while(true){
        int k;
        scanf("%d",&k);
        if(k<=0)
            return 0;
        printf("%d: ",t++);
        if(pri[k])
            printf("yes\n");
        else
            printf("no\n");
    }
}

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/80706192
hdu